#1897: Upgrade to rails 2.3

Type: FeatureItem Feature: DebianPackage Tags: blogoosfero
ScheduledFor: 0.36.0 Assigned to: AntonioTerceiro Task Points: 27
Priority: 0 Status: Done  

As we decided to follow Debian Stable, its time to migrate the Noosfero to Rails 2.3.5, which is the Rails version in Debian Squeeze.

  1. Update Debian package
  2. Setup Noosfero environment with all new dependencies in Debian Squeeze
  3. Upgrade all production servers to Debian Squeeze and Noosfero + Rails 2.3.5
  4. Patch review and small fixes in patch

The work is being done in git branch below:

It is interesting to keep Noosfero compatible with both Rails 2.1.0 and Rails 2.3.5.

-- JoenioCosta - 23 Feb 2011

I don't think it's feasible to keep Noosfero working with both Rails versions ... I think planning and documenting the transition for others is a better use of people's time ...

-- AntonioTerceiro - 23 Feb 2011

Ok, I agree.

-- JoenioCosta - 23 Feb 2011

checklist:

Status Description Notes
DONE merge the master branch in the 2.3.5 branch, point vendor/rails to rails 2.3.5 and make sure tests pass on Debian Squeeze work branch
DONE migrate Debian package from mongrel to thin
DONE test installation on Debian Squeeze, fix the package until it works  
DONE test upgrade from Debian Lenny + Noosfero for Lenny to Debian Squeeze + Noosfero for Squeeze  
DONE On Lenny upgrades, migrate configured number of servers from mongrel to thin  
DONE merge the rails-2.3.5 branch into master  
  split the Debian repository by Debian release. Move the current repo to a 'debian/lenny' folder, and create a new one called 'debian/squeeze'  
  update installation instructions  
DONE decide on a maintainance policy for the 0.35.x series on Debian Lenny (only critical bugs?) only critical bugs (security problems and data loss)
choice-no merge in the Gemfile that was contributed and test a Noosfero bootstrap with bundler without any of the Debian packages didn't have the time to do this. See DepsWithRVMAndGems for now
choice-no investigate the possibility to replace attachment_fu with other plugin see this message. // didn't have time to do this. Things seem to work, though.

-- AntonioTerceiro - 26 Nov 2011

feedback: several of the failing tests under squeeze were due to wrong/incomplete/too strict mocking

-- AntonioTerceiro - 08 Dec 2011

just made all unit/functional/integration tests pass with rails 2.3 under debian squeeze

-- AntonioTerceiro - 09 Dec 2011

the mongrel version on Squeeze is broken. We will be migrating over to thin. another reason is that mongrel seems to be abandoned: the latest release was in 2008, and it's the same version that is in Debian. So we are definitively moving over to thin.

-- AntonioTerceiro - 10 Jan 2012

Altough Thin is way better than Mongrel, Goliath seems to be an even better option. For a comparizon see WebServer. But there isn't a debian package for it (again we stick with debian).

-- BraulioBhavamitraBO - 17 Jan 2012

other important point: please note that including %{fn} in translatable strings for AR error messages is now deprecated. I've kept the existing ones to avoid invalidating translations, but we should not add any new ones.

-- AntonioTerceiro - 27 Jan 2012

other point: letting pluging add columns to existing tables is bad.

-- AntonioTerceiro - 27 Jan 2012

On production mode, when I was doing some action that needed to send e-mails, there was an error:

OpenSSL::SSL::SSLError (hostname was not match with the server certificate):
  /usr/lib/ruby/1.8/openssl/ssl-internal.rb:123:in `post_connection_check'
  /usr/lib/ruby/1.8/net/smtp.rb:582:in `tlsconnect'
  /usr/lib/ruby/1.8/net/smtp.rb:562:in `do_start'
  /usr/lib/ruby/1.8/net/smtp.rb:525:in `start'
Information about it: http://scottiestech.info/2009/12/21/fixing-the-actionmailer-hostname-not-match-server-certificate-error/

-- DanielaFeitosa - 29 Feb 2012

notes from actual Lenny+Noosfero 0.35 → Squeeze + Noosfero 0.36.0 upgrades:

  • upgrading to 0.36.0 needs to be from 0.35.2, i.e. you should first upgrade to the latest lenny version available before upgrading to the squeeze version.
  • it takes quite a while to to upgrade. Plan for for at least some 2 hours of downtime
  • on the VM I tested, even with apt-get -q -y dist-upgrade, the upgrade of console-tools stops asking about what to do with a config file. Pay attention so that you can type "Y" (or the better response on your case) to allow the upgrade to proceed.
  • it might be necessary to restart apache after the upgrade finishes.

-- AntonioTerceiro - 03 Mar 2012

Add comment
You need to login to be able to comment.
 

ActionItemForm edit

Title Upgrade to rails 2.3
ActionItemType? FeatureItem
Priority 0
Tags blogoosfero
Feature DebianPackage
Plugin
TaskPoints? 27
ResponsibleDevelopers AntonioTerceiro
ScheduledFor? 0.36.0
AffectsVersion?
Status Done
Ticket SAC:
Topic revision: r29 - 27 Apr 2012 - 12:19:43 - BraulioBhavamitraBO

irc Talk with Devs Now!

 
Translations: English
Search on Docs:
   
ActionItem Search:

Copyright © 2007-2014 by the Noosfero contributors
Colivre - Cooperativa de Tecnologias Livres