#2372: Noosfero won't start after reboot on a new install

Type: BugItem Feature: DebianPackage, Infrastructure Tags:  
ScheduledFor: 0.38.0 Assigned to: AntonioTerceiro Sites:  
Priority: 10 Status: Done  

Description of the bug

When Noosfero is installed as a Debian package (or when the provided initscript is used somehow), and the system used dependency-based boot, Noosfero may not start properly after a reboot. That's because Noosfero it may be scheduled to start before PostgreSQL, what will obviously fail. This happens because the provided initscript does not contain required LSB headers indicating the dependency on PostgreSQL.

Reference: http://wiki.debian.org/LSBInitScripts

Steps to reproduce

  1. Install Noosfero using the Debian package on a clean Debian Squeeze system
  2. Reboot
  3. Check that Noosfero won't start properly after the reboot.

-- AntonioTerceiro -- 28 Jun 2012

https://gitorious.org/noosfero/noosfero/merge_requests/179

-- AntonioTerceiro - 28 Jun 2012

Add comment
You need to login to be able to comment.
 

ActionItemForm edit

Title Noosfero won't start after reboot on a new install
ActionItemType? BugItem
Priority 10
Tags
Feature DebianPackage, Infrastructure
Plugin
ResponsibleDevelopers AntonioTerceiro
ScheduledFor? 0.38.0
AffectsVersion? 0.37.0
Status Done
Ticket SAC:
Topic revision: r2 - 16 Jul 2012 - 13:14:40 - DanielaFeitosa
 
Translations: English
Search on Docs:
   
ActionItem Search:

Copyright © 2007-2014 by the Noosfero contributors
Colivre - Cooperativa de Tecnologias Livres