Install dependencies using RVM and GEMs

Packages dependencies

Noosfero deps
sudo apt-get install po4a iso-codes tango-icon-theme pidgin-data curl default-jre

Gems' extensions deps
sudo apt-get install libmagickwand-dev libpq-dev libreadline-dev libsqlite3-dev libxslt1-dev

RVM

RVM is useful if you don't have sudo access and/or want a installation inside your user

Install

curl -L https://get.rvm.io | bash -s stable source "$HOME/.rvm/scripts/rvm"

Add a ruby and gemset

RUBY=2.1.5
rvm install $RUBY
rvm use $RUBY@noosfero --create
rvm use $RUBY@noosfero

Install gems

Just run bundle
bundle install

Gotchas

locale gem version 2.1.0 has problems with gettext 2.x. So please downgrade to 2.0.9. That will be fixed soon in Noosfero's Gemfile.

Add comment
You need to login to be able to comment.
 
Topic revision: r2 - 18 Aug 2016, RodrigoSouto

irc Talk with Devs Now!

 
Translations: English
Search on Docs:
   
ActionItem Search:

Copyright © 2007-2018 by the Noosfero contributors
Colivre - Cooperativa de Tecnologias Livres